FCIB - FAC MERCHANT NOTIFICATION - Mastercard 3DS Outage
Incident Report for FAC FCIB
Resolved
This incident has been resolved.
Posted Jun 12, 2023 - 16:20 UTC
Investigating
To our valued clients,

Mastercard has advised that are experiencing an issue with 3DS authentications resulting in an outage for some Mastercard transactions. We are monitoring the situation and will confirm once resolved.


The FAC Support Team
Posted Jun 12, 2023 - 12:29 UTC
This incident affected: FCIB/CIBC Merchants.